Debian Lenny to Squeeze upgrade

Debian Lenny to Squeeze upgrade

Debian 6 i.e. “Squeeze” was released almost a month ago. Although there are still about 11 months more before Debian 5 “Lenny” is no longer supported, I figured I would upgrade one Debian Lenny Xen-based VPS hosted on a Rackspace Cloud,  currently functioning as an OpenLDAP server, as a weekend project. The upgrade steps were straightforward: 1. Edit /etc/apt/sources.list and change all instances of lenny to squeeze. 2. Run the following commands in succession in terminal sudo apt-get update sudo apt-get install apt dpkg aptitude sudo apt-get dist-upgrade Surprisingly enough the upgrade went well with Apache and even OpenLDAP migrated successfully. Just the following issues related to phpldapadmin were encountered: 1. The upgraded...

Read More